6,624 packages matching “rfc-7517”
cose-to-jwk
v1.1.0 · 8 years ago
COSE (RFC 8152) to JWK (RFC 7517) converter for node.js. Created for WebAuthn.
No known vulnerabilities
@exortek/jwk
v1.0.4 · 1 month ago
JSON Web Key (JWK) — RFC 7517 / RFC 7638 / RFC 8037 for Node.js. Generate, import, export, thumbprint EC / RSA / OKP / oct keys. Zero-dependency, built on node:crypto.
No known vulnerabilities
jwk-utils
v0.1.0 · 6 years ago
A Node.js library for working with the JSON Web Key format (RFC #7517).
No known vulnerabilities
node-jose
v2.2.0 · 3 years ago
A JavaScript implementation of the JSON Object Signing and Encryption (JOSE) for current web browsers and node.js-based servers
No known vulnerabilities
uri-js
v4.4.1 · 5 years ago
An RFC 3986/3987 compliant, scheme extendable URI/IRI parsing/validating/resolving library for JavaScript.
No known vulnerabilities
jwk-schema
v1.0.0 · 6 years ago
JSON Schema and TypeScript Types for JSON Web Keys, as defined IETF RFC 7517.
No known vulnerabilities
fast-uri
v4.2.1 · 15 days ago
Dependency-free RFC 3986 URI toolbox
No known vulnerabilities
@peculiar/asn1-ecc
v2.10.0 · 6 days ago
ASN.1 schema for elliptic-curve private keys and related identifiers defined in RFC 5915, RFC 5480, and RFC 3279.
No known vulnerabilities
pkijs
v3.4.1 · 13 days ago
Public Key Infrastructure (PKI) is the basis of how identity and key management is performed on the web today. PKIjs is a pure JavaScript library implementing the formats that are used in PKI applications. It is built on WebCrypto and aspires to make it p
No known vulnerabilities
win-guid
v0.2.1 · 8 months ago
Windows legacy GUID parser
No known vulnerabilities
@peculiar/asn1-x509-logotype
v2.10.0 · 6 days ago
ASN.1 schema for X.509 certificate logotype extensions defined in RFC 3709 and RFC 9399.
No known vulnerabilities
punycode
v2.3.1 · 2 years ago
A robust Punycode converter that fully complies to RFC 3492 and RFC 5891, and works on nearly all JavaScript platforms.
No known vulnerabilities
http-link-header
v1.1.4 · 2 months ago
Parse & format HTTP link headers according to RFC 8288
No known vulnerabilities
email-addresses
v5.0.0 · 5 years ago
An email address parser based on rfc5322
No known vulnerabilities
@peculiar/asn1-rsa
v2.10.0 · 6 days ago
ASN.1 schema for RSA keys and algorithms defined in RFC 8017.
No known vulnerabilities
@peculiar/asn1-csr
v2.10.0 · 6 days ago
ASN.1 schema for PKCS #10 certificate signing requests defined in RFC 2986.
No known vulnerabilities
@peculiar/asn1-pkcs9
v2.10.0 · 6 days ago
ASN.1 schema for PKCS #9 selected attribute types defined in RFC 2985.
No known vulnerabilities
@peculiar/asn1-pfx
v2.10.0 · 6 days ago
ASN.1 schema for PKCS #12 personal information exchange structures defined in RFC 7292.
No known vulnerabilities
@peculiar/asn1-cms
v2.10.0 · 6 days ago
ASN.1 schema for Cryptographic Message Syntax (CMS) defined in RFC 5652.
No known vulnerabilities
@peculiar/asn1-pkcs8
v2.10.0 · 6 days ago
ASN.1 schema for PKCS #8 private key information structures defined in RFC 5208.
No known vulnerabilities