1,323,738 packages matching “parse domain of email address”
email-addresses
v5.0.0 · 5 years ago
An email address parser based on rfc5322
No known vulnerabilities
@sideway/address
v5.0.0 · 4 years ago
Email address and domain validation
No known vulnerabilities
@hapi/address
v5.1.1 · 3 years ago
Email address and domain validation
No known vulnerabilities
smtp-address-parser
v1.1.0 · 2 years ago
Parse an SMTP (RFC-5321) address
No known vulnerabilities
parse-email-address
v0.0.5 · 29 days ago
Parse/validate email addresses with RFC-5321, and message header address lists with RFC-5322.
No known vulnerabilities
tldts
v7.4.16 · 3 days ago
Library to work against complex domain names, subdomains and URIs.
No known vulnerabilities
free-email-domains-list
v1.0.16 · 1 year ago
Fresh list of all free email domain providers. Can be used to check if an email address belongs to a company. Updated weekly.
No known vulnerabilities
address-rfc2821
v2.2.1 · 4 months ago
RFC-5321 (Envelope) email address parser
No known vulnerabilities
parse-author
v2.0.0 · 9 years ago
Parse an author, contributor, maintainer or other 'person' string into an object with name, email and url properties following npm conventions.
No known vulnerabilities
parse-domain
v8.4.0 · 1 month ago
Splits a hostname into subdomains, domain and (effective) top-level domains
No known vulnerabilities
fast-uri
v4.2.1 · 12 days ago
Dependency-free RFC 3986 URI toolbox
No known vulnerabilities
tld-extract
v2.1.0 · 3 years ago
Extract the TLD/domain/subdomain parts of an URL/hostname against mozilla TLDs 'official' listing .
No known vulnerabilities
@hutson/parse-repository-url
v5.0.0 · 6 years ago
Parse repository URLs to extract, SCM platform, domain, user, and project information.
No known vulnerabilities
@strapi/provider-email-sendmail
v5.56.0 · 9 hours ago
Sendmail provider for strapi email
No known vulnerabilities
pg-connection-string
v2.14.1 · 5 hours ago
Functions for dealing with a PostgreSQL connection string
No known vulnerabilities
tldts-icann
v7.4.16 · 3 days ago
Library to work against complex domain names, subdomains and URIs. Only contains ICANN section.
No known vulnerabilities
ipaddr.js
v2.5.0 · 1 month ago
A library for manipulating IPv4 and IPv6 addresses in JavaScript.
No known vulnerabilities
@sendgrid/helpers
v8.0.0 · 2 years ago
Twilio SendGrid NodeJS internal helpers
No known vulnerabilities
github-username
v9.0.0 · 1 year ago
Get a GitHub username from an email address
No known vulnerabilities
forwarded
v0.2.0 · 5 years ago
Parse HTTP X-Forwarded-For header
No known vulnerabilities