6,617 packages matching “RFC 7519”
cf-jwt
v1.0.4 · 4 years ago
A simple JWT library for Cloudflare Workers that complies with RFC 7519.
No known vulnerabilities
@exortek/jwt
v1.3.0 · 1 month ago
JSON Web Token (JWT) — RFC 7519 / RFC 7518 / RFC 8725 / RFC 9068 for Node.js 22+. sign / verify / decode / peek, tokenPair (access + refresh) with reuse detection, blacklist store (memory / redis / custom), claims validation (exp / nbf / iat / iss / aud /
No known vulnerabilities
fast-jwt
v6.3.3 · 1 month ago
Fast JSON Web Token implementation
No known vulnerabilities
@panmdaa/jwt
v0.1.1 · 27 days ago
Zero-dependency TypeScript library for signing and verifying JSON Web Tokens (HMAC, RSA, ECDSA) based on RFC 7519/7515/7518
No known vulnerabilities
uri-js
v4.4.1 · 5 years ago
An RFC 3986/3987 compliant, scheme extendable URI/IRI parsing/validating/resolving library for JavaScript.
No known vulnerabilities
fast-uri
v4.2.1 · 16 days ago
Dependency-free RFC 3986 URI toolbox
No known vulnerabilities
@peculiar/asn1-ecc
v2.10.0 · 7 days ago
ASN.1 schema for elliptic-curve private keys and related identifiers defined in RFC 5915, RFC 5480, and RFC 3279.
No known vulnerabilities
pkijs
v3.4.1 · 13 days ago
Public Key Infrastructure (PKI) is the basis of how identity and key management is performed on the web today. PKIjs is a pure JavaScript library implementing the formats that are used in PKI applications. It is built on WebCrypto and aspires to make it p
No known vulnerabilities
win-guid
v0.2.1 · 8 months ago
Windows legacy GUID parser
No known vulnerabilities
@peculiar/asn1-x509-logotype
v2.10.0 · 7 days ago
ASN.1 schema for X.509 certificate logotype extensions defined in RFC 3709 and RFC 9399.
No known vulnerabilities
punycode
v2.3.1 · 2 years ago
A robust Punycode converter that fully complies to RFC 3492 and RFC 5891, and works on nearly all JavaScript platforms.
No known vulnerabilities
http-link-header
v1.1.4 · 2 months ago
Parse & format HTTP link headers according to RFC 8288
No known vulnerabilities
email-addresses
v5.0.0 · 5 years ago
An email address parser based on rfc5322
No known vulnerabilities
@peculiar/asn1-rsa
v2.10.0 · 7 days ago
ASN.1 schema for RSA keys and algorithms defined in RFC 8017.
No known vulnerabilities
@peculiar/asn1-csr
v2.10.0 · 7 days ago
ASN.1 schema for PKCS #10 certificate signing requests defined in RFC 2986.
No known vulnerabilities
@peculiar/asn1-pkcs9
v2.10.0 · 7 days ago
ASN.1 schema for PKCS #9 selected attribute types defined in RFC 2985.
No known vulnerabilities
@peculiar/asn1-pfx
v2.10.0 · 7 days ago
ASN.1 schema for PKCS #12 personal information exchange structures defined in RFC 7292.
No known vulnerabilities
@peculiar/asn1-cms
v2.10.0 · 7 days ago
ASN.1 schema for Cryptographic Message Syntax (CMS) defined in RFC 5652.
No known vulnerabilities
@peculiar/asn1-pkcs8
v2.10.0 · 7 days ago
ASN.1 schema for PKCS #8 private key information structures defined in RFC 5208.
No known vulnerabilities
@peculiar/asn1-x509
v2.10.0 · 7 days ago
ASN.1 schema for X.509 certificates, certificate revocation lists, and related profile structures defined in RFC 5280.
No known vulnerabilities