502 packages matching “JWS”
@types/jws
v3.2.11 · 11 months ago
TypeScript definitions for jws
No known vulnerabilities
jwa
v2.0.1 · 1 year ago
JWA implementation (supports all JWS algorithms)
No known vulnerabilities
jose
v6.2.12 · 29 days ago
JWA, JWS, JWE, JWT, JWK, JWKS for Node.js, Browser, Cloudflare Workers, Deno, Bun, and other Web-interoperable runtimes
No known vulnerabilities
jws
v4.0.1 · 10 months ago
Implementation of JSON Web Signatures
No known vulnerabilities
base64url-universal
v2.0.0 · 4 years ago
Encode/decode "Base64url Encoding" format of JSON Web Signature (JWS) RFC7517.
No known vulnerabilities
node-webtokens
v1.0.4 · 6 years ago
Simple, opinionated implementation of JWS and JWE compact serialization
No known vulnerabilities
jose-jwe-jws
v0.2.2 · 6 years ago
Library to encrypt and decrypt data in JSON Web Encryption (JWE) format and to sign data in JSON Web Signature (JWS) format. Leverages Browser's native web crypto API.
No known vulnerabilities
@digitalcredentials/base64url-universal
v2.0.6 · 2 years ago
Encode/decode "Base64url Encoding" format of JSON Web Signature (JWS) RFC7517.
No known vulnerabilities
@transmute/es256k-jws-ts
v0.1.3 · 6 years ago
TypeScript Web Assembly Secp256k1 ES256K JWS and JWT.
No known vulnerabilities
jws-jwk
v0.1.4 · 12 years ago
Adds (some) support for JWKs to node-jws
No known vulnerabilities
@dnsid-ai/jose
v0.24.2 · 3 days ago
DNSid JOSE JWT and JWS profile helpers.
No known vulnerabilities
node-jws-file-provider
v0.1.4 · 5 years ago
File Provider for node-jws handling signatures/verification using file-based keys
No known vulnerabilities
@peac/crypto
v0.16.4 · 1 month ago
Ed25519 JWS signing and verification for PEAC protocol
No known vulnerabilities
@absolutejs/agent-exchange-mandate-webcrypto
v0.2.0 · 1 month ago
Non-exportable WebCrypto ES256 JWS provider for Agent Exchange standing mandates.
No known vulnerabilities
green-jwt
v0.0.8-alpha · 12 years ago
Node implementation of JSON Web Token (JWT) with support for signatures (JWS), encryption (JWE) and web keys (JWK).
No known vulnerabilities
@di-framework/auth
v6.0.4 · 15 hours ago
Authentication for di-framework — sessions, JWT/JWS bearer, OAuth2/OIDC, and WebAuthn passkeys on WebCrypto with zero runtime dependencies
No known vulnerabilities
@docknetwork/crypto-utils
v0.2.3 · 2 months ago
Lightweight Dock keypairs, crypto value types, byte utilities, and JWS helpers
No known vulnerabilities
oada-trusted-jws
v1.0.5 · 6 years ago
Check if a JWS was signed by an OADA trusted party
No known vulnerabilities
@exortek/jws
v1.0.4 · 1 month ago
JSON Web Signature (JWS) — RFC 7515 / RFC 7518 / RFC 7797 / RFC 8037 / RFC 8812 for Node.js 22+. Compact + JSON serialization, detached content, unencoded payload, HS/RS/PS/ES/EdDSA. Alg allowlist mandatory. `none` never accepted. Zero-dependency, built o
No known vulnerabilities
x402-verify
v1.11.0 · 2 days ago
Zero-dependency verifier for x402 Signed Offers & Receipts: compact JWS or x402 JWS envelopes (EdDSA/Ed25519), did:web resolution, local revision-1 schema checks, explicit result statuses, and optional anchored key history.
No known vulnerabilities