6,625 packages matching “rfc-7517”

toad-uri-js

v5.0.1 · 2 years ago

90
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

A modern RFC 3986/3987 compliant, scheme extendable URI/IRI parsing/normalizing/resolving/serializing library for JavaScript.

91.7KDownloads across all versions in the last 7 days, from the official npm downloads API.BSD-2-Clause-ViewsLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v5.0.1 (the latest release), from the OSV.dev database.

foldline

v2.0.0 · 7 months ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Folds a long line according to the RFC 5322

445.5KDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.0.0 (the latest release), from the OSV.dev database.

url-template

v3.1.1 · 2 years ago

90
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

A URI template implementation (RFC 6570 compliant)

21.0MDownloads across all versions in the last 7 days, from the official npm downloads API.BSD-3-ClauseLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v3.1.1 (the latest release), from the OSV.dev database.

cacheable-request

v13.0.19 · 4 months ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Wrap native HTTP requests with RFC compliant cache support

44.1MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v13.0.19 (the latest release), from the OSV.dev database.

fast-content-type-parse

v4.0.0 · 1 month ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Parse HTTP Content-Type header according to RFC 9110

19.6MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v4.0.0 (the latest release), from the OSV.dev database.

rrule-temporal

v2.2.8 · 2 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Recurrence rule (rrule) processing using Temporal PlainDate/PlainDateTime, with cross-timezone and cross-calendar rrule support

1.1MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.2.8 (the latest release), from the OSV.dev database.

otplib

v13.5.0 · 1 month ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

TypeScript-first library for TOTP and HOTP with multi-runtime and plugin support

4.3MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v13.5.0 (the latest release), from the OSV.dev database.

dns-txt

v2.0.2 · 10 years ago

85
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Encode/decode DNS-SD TXT record RDATA fields

2.0MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.0.2 (the latest release), from the OSV.dev database.

@peculiar/asn1-asym-key

v2.10.0 · 7 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

ASN.1 schema for asymmetric key packages and OneAsymmetricKey structures defined in RFC 5958.

1.4MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.10.0 (the latest release), from the OSV.dev database.

schemes

v1.4.0 · 5 years ago

85
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

IANA Uniform Resource Identifier (URI) Schemes list, including crowd sourced unofficial ones

1.0MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.4.0 (the latest release), from the OSV.dev database.

language-tags

v2.1.0 · 1 year ago

95
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Work with IANA language tags.

58.0MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.1.0 (the latest release), from the OSV.dev database.

@types/valid-url

v1.0.7 · 2 years ago

90
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

TypeScript definitions for valid-url

160.5KDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.0.7 (the latest release), from the OSV.dev database.

ts-essentials

v10.2.1 · 4 months ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

All essential TypeScript types in one place

7.8MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v10.2.1 (the latest release), from the OSV.dev database.

@tufjs/canonical-json

v2.0.0 · 3 years ago

85
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

OLPC JSON canonicalization

12.2MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.0.0 (the latest release), from the OSV.dev database.

http-cache-semantics

v4.3.0 · 9 hours ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Parses Cache-Control and other headers. Helps building correct HTTP caches and proxies

60.4MDownloads across all versions in the last 7 days, from the official npm downloads API.BSD-2-ClauseLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v4.3.0 (the latest release), from the OSV.dev database.

@fedify/uri-template

v2.4.0 · 3 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

RFC 6570 URI Template expansion and round-trip pattern matching

26.7KDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.4.0 (the latest release), from the OSV.dev database.

@hyperjump/uri

v1.3.8 · 19 hours ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

A small and fast library for validating parsing and resolving URIs and IRIs

460.2KDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.3.8 (the latest release), from the OSV.dev database.

jsonpathly

v3.0.1 · 12 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

RFC 9535 compliant JSONPath query library for TypeScript/JavaScript - secure, fast, and dependency-free

759.0KDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v3.0.1 (the latest release), from the OSV.dev database.

openpgp

v6.3.2 · 10 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

OpenPGP.js is a Javascript implementation of the OpenPGP protocol. This is defined in RFC 4880.

1.5MDownloads across all versions in the last 7 days, from the official npm downloads API.LGPL-3.0+License declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v6.3.2 (the latest release), from the OSV.dev database.

glossy

v0.1.7 · 11 years ago

85
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Syslog parser and producer

141.0KDownloads across all versions in the last 7 days, from the official npm downloads API.

No known vulnerabilities

Known vulnerabilities affecting v0.1.7 (the latest release), from the OSV.dev database.