6,625 packages matching “rfc-7517”

@peculiar/asn1-x509

v2.10.0 · 6 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

ASN.1 schema for X.509 certificates, certificate revocation lists, and related profile structures defined in RFC 5280.

17.4MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.10.0 (the latest release), from the OSV.dev database.

@scure/base

v2.4.0 · 1 month ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Secure, audited & 0-dep implementation of base64, bech32, base58, base32 & base16

12.7MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.4.0 (the latest release), from the OSV.dev database.

@peculiar/asn1-x509-attr

v2.10.0 · 6 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

ASN.1 schema for X.509 attribute certificates defined in RFC 5755.

16.1MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.10.0 (the latest release), from the OSV.dev database.

@homebridge/ciao

v1.3.12 · 1 month ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

ciao is a RFC 6763 compliant dns-sd library, advertising on multicast dns (RFC 6762) implemented in plain Typescript/JavaScript

4.1MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.3.12 (the latest release), from the OSV.dev database.

cbor-x

v1.6.6 · 1 month ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Ultra-fast and conformant CBOR (RFC 8949) implementation with support for numerous tag extensions including records and structured cloning

3.4MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.6.6 (the latest release), from the OSV.dev database.

punycode.js

v2.3.1 · 2 years ago

90
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

A robust Punycode converter that fully complies to RFC 3492 and RFC 5891, and works on nearly all JavaScript platforms.

31.6MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v2.3.1 (the latest release), from the OSV.dev database.

valid-data-url

v5.0.0 · 3 years ago

85
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Detect if a string is a data URL

3.7MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v5.0.0 (the latest release), from the OSV.dev database.

smtp-address-parser

v1.1.0 · 2 years ago

90
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Parse an SMTP (RFC-5321) address

1.6MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.1.0 (the latest release), from the OSV.dev database.

jsc-safe-url

v0.2.4 · 3 years ago

85
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Utility functions for converting to and from URLs that encode query string data into URL paths

14.1MDownloads across all versions in the last 7 days, from the official npm downloads API.0BSDLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v0.2.4 (the latest release), from the OSV.dev database.

tinyspy

v4.0.6 · 29 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

A minimal fork of nanospy, with more features

64.3MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v4.0.6 (the latest release), from the OSV.dev database.

@lezer/json

v1.0.3 · 1 year ago

95
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

lezer-based JSON grammar

9.4MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.0.3 (the latest release), from the OSV.dev database.

@guarani/jose

v1.1.2 · 19 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Implementation of the RFCs of the JOSE Working Group.

30Downloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.1.2 (the latest release), from the OSV.dev database.

idn-hostname

v17.0.4 · 19 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

An internationalized hostname validator as defined by RFC5890, RFC5891, RFC5892, RFC5893, RFC3492 and UTS#46

342.3KDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v17.0.4 (the latest release), from the OSV.dev database.

tough-cookie

v6.0.2 · 2 months ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

RFC6265 Cookies and Cookie Jar for node.js

161.0MDownloads across all versions in the last 7 days, from the official npm downloads API.BSD-3-ClauseLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v6.0.2 (the latest release), from the OSV.dev database.

parse-cosekey

v1.0.2 · 4 years ago

85
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Parse COSE(CBOR Object Signing and Encryption) to JWK(JSON Web Key) or PEM.

2.8KDownloads across all versions in the last 7 days, from the official npm downloads API.Apache-2.0License declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.0.2 (the latest release), from the OSV.dev database.

@oslojs/encoding

v1.1.0 · 2 years ago

90
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Runtime-agnostic library for encoding and decoding data

10.5MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.1.0 (the latest release), from the OSV.dev database.

uuid

v14.0.2 · 1 month ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

RFC9562 UUIDs

354.1MDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v14.0.2 (the latest release), from the OSV.dev database.

lettercoder

v0.1.1 · 2 years ago

90
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

Quoted-printable (RFC 2045) and mime word (RFC 2047) decoding

56.6KDownloads across all versions in the last 7 days, from the official npm downloads API.BSD-3-Clause-ClearLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v0.1.1 (the latest release), from the OSV.dev database.

toad-uri-js

v5.0.1 · 2 years ago

90
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

A modern RFC 3986/3987 compliant, scheme extendable URI/IRI parsing/normalizing/resolving/serializing library for JavaScript.

102.7KDownloads across all versions in the last 7 days, from the official npm downloads API.BSD-2-Clause-ViewsLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v5.0.1 (the latest release), from the OSV.dev database.

@better-auth/scim

v1.7.7 · 3 days ago

100
0-100 score computed by this site from verifiable signals only: known OSV.dev advisories affecting this exact version, how recently it was published, and the repository's OpenSSF Scorecard.

SCIM plugin for Better Auth

203.9KDownloads across all versions in the last 7 days, from the official npm downloads API.MITLicense declared in the package manifest.

No known vulnerabilities

Known vulnerabilities affecting v1.7.7 (the latest release), from the OSV.dev database.