871,798 packages matching “Web Cryptography API”
elliptic
v6.6.1 · 1 year ago
EC cryptography
1 low
bigint-crypto-utils
v3.3.0 · 3 years ago
Arbitrary precision modular arithmetic, cryptographically secure random numbers and strong probable prime generation/testing. It works in modern browsers, Angular, React, Node.js, etc. since it uses the native JS implementation of BigInt
No known vulnerabilities
aenigma
v0.1.1 · 8 years ago
User-friendly AngularJS encryption module utilizing the Web Cryptography API and providing an extensible secure secret storage mechanism.
No known vulnerabilities
@memoorje/crypto
v0.1.0 · 4 years ago
Encryption container formats based on the Web Cryptography API
No known vulnerabilities
bigint-mod-arith
v3.3.1 · 3 years ago
Some common functions for modular arithmetic using native JS implementation of BigInt
No known vulnerabilities
paillier-bigint
v3.4.3 · 3 years ago
An implementation of the Paillier cryptosystem using native JS (ECMA 2020) implementation of BigInt
No known vulnerabilities
@aws-sdk/client-payment-cryptography
v3.1146.0 · 1 day ago
AWS SDK for JavaScript Payment Cryptography Client for Node.js, Browser and React Native
No known vulnerabilities
@noble/ed25519
v3.2.0 · 1 month ago
Fastest 5KB JS implementation of ed25519 EDDSA signatures compliant with RFC8032, FIPS 186-5 & ZIP215
No known vulnerabilities
@noble/secp256k1
v3.2.0 · 1 month ago
Fastest 5KB JS implementation of secp256k1 ECDH & ECDSA signatures compliant with RFC6979
No known vulnerabilities
openpgp
v6.3.2 · 10 days ago
OpenPGP.js is a Javascript implementation of the OpenPGP protocol. This is defined in RFC 4880.
No known vulnerabilities
@noble/post-quantum
v0.7.1 · 1 month ago
Auditable & minimal JS implementation of post-quantum cryptography: FIPS 203, 204, 205, Falcon
No known vulnerabilities
@ethereumjs/common
v10.1.3 · 1 month ago
Resources common to all Ethereum implementations
No known vulnerabilities
webview-crypto
v0.1.14 · 8 months ago
Helper code for crypto polyfil in a webview
No known vulnerabilities
@cryptography/sha1
v0.2.0 · 6 years ago
High-performance synchronous SHA-1 implementation for JavaScript
No known vulnerabilities
subtlepq
v0.4.0 · 2 months ago
Post-quantum polyfill for the Web Cryptography API: ML-KEM (FIPS 203) and ML-DSA (FIPS 204) per the WICG Modern Algorithms draft, with native delegation
No known vulnerabilities
@aws-sdk/client-payment-cryptography-data
v3.1146.0 · 1 day ago
AWS SDK for JavaScript Payment Cryptography Data Client for Node.js, Browser and React Native
No known vulnerabilities
tlock-js
v0.9.0 · 2 years ago
A library to encrypt data that can only be decrypted in the future using drand
No known vulnerabilities
@hpke/core
v1.9.0 · 6 months ago
A Hybrid Public Key Encryption (HPKE) core module for various JavaScript runtimes
No known vulnerabilities
forge-light
v1.1.4 · 2 years ago
A custom version of node-forge with selected algorithms.
No known vulnerabilities
@aws-sdk/credential-provider-web-identity
v3.972.78 · 11 days ago
AWS credential provider that calls STS assumeRole for temporary AWS credentials
No known vulnerabilities