7,739 packages matching “RFC 6455”
bif-websocket
v1.0.29 · 7 years ago
Websocket Client & Server Library implementing the WebSocket protocol as specified in RFC 6455.
No known vulnerabilities
@undercroft/pulse-frame
v1.0.2 · 1 year ago
Low-level WebSocket framing library implementing RFC 6455. Supports payload masking, control frames, and binary/text handling.
No known vulnerabilities
websocket-without-native
v1.0.23 · 10 years ago
Websocket Client & Server Library implementing the WebSocket protocol as specified in RFC 6455.
No known vulnerabilities
ws-without-native
v1.0.2 · 10 years ago
simple to use, blazing fast and thoroughly tested websocket client, server and console for node.js, up-to-date against RFC-6455
No known vulnerabilities
ws-interface
v1.2.0 · 10 years ago
simple to use, blazing fast and thoroughly tested websocket client, server and console for node.js, up-to-date against RFC-6455
No known vulnerabilities
@peculiar/asn1-ecc
v2.10.0 · 4 days ago
ASN.1 schema for elliptic-curve private keys and related identifiers defined in RFC 5915, RFC 5480, and RFC 3279.
No known vulnerabilities
fast-uri
v4.2.1 · 13 days ago
Dependency-free RFC 3986 URI toolbox
No known vulnerabilities
@p-vbordei/ws-reconnect
v0.2.1 · 4 months ago
Pure helpers for WebSocket reconnection: exponential backoff with jitter, sequence-gap classifier, RFC 6455 close-code lookup. Zero dependencies.
No known vulnerabilities
@nomiclabs/websocket
v1.0.31 · 6 years ago
Websocket Client & Server Library implementing the WebSocket protocol as specified in RFC 6455.
No known vulnerabilities
pkijs
v3.4.1 · 11 days ago
Public Key Infrastructure (PKI) is the basis of how identity and key management is performed on the web today. PKIjs is a pure JavaScript library implementing the formats that are used in PKI applications. It is built on WebCrypto and aspires to make it p
No known vulnerabilities
win-guid
v0.2.1 · 8 months ago
Windows legacy GUID parser
No known vulnerabilities
@peculiar/asn1-x509-logotype
v2.10.0 · 4 days ago
ASN.1 schema for X.509 certificate logotype extensions defined in RFC 3709 and RFC 9399.
No known vulnerabilities
punycode
v2.3.1 · 2 years ago
A robust Punycode converter that fully complies to RFC 3492 and RFC 5891, and works on nearly all JavaScript platforms.
No known vulnerabilities
websocket-in-node
v1.0.34 · 3 years ago
Websocket Client & Server Library implementing the WebSocket protocol as specified in RFC 6455.
No known vulnerabilities
http-link-header
v1.1.4 · 2 months ago
Parse & format HTTP link headers according to RFC 8288
No known vulnerabilities
email-addresses
v5.0.0 · 5 years ago
An email address parser based on rfc5322
No known vulnerabilities
@peculiar/asn1-rsa
v2.10.0 · 4 days ago
ASN.1 schema for RSA keys and algorithms defined in RFC 8017.
No known vulnerabilities
@peculiar/asn1-pfx
v2.10.0 · 4 days ago
ASN.1 schema for PKCS #12 personal information exchange structures defined in RFC 7292.
No known vulnerabilities
@peculiar/asn1-cms
v2.10.0 · 4 days ago
ASN.1 schema for Cryptographic Message Syntax (CMS) defined in RFC 5652.
No known vulnerabilities
@peculiar/asn1-pkcs9
v2.10.0 · 4 days ago
ASN.1 schema for PKCS #9 selected attribute types defined in RFC 2985.
No known vulnerabilities